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About this guide  

This guide is designed to provide a quick introduction to PROMODAG Reports for Microsoft Exchange 
Server, and it describes steps from getting started to producing the first report.  

For more details about specific features of PROMODAG Reports, please refer to the online Help system.  
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Presentation 

PROMODAG Reports is an advanced and cost-effective reporting tool that enables Exchange Server 
administrators and IT managers to obtain valuable information about all aspects of their email system. 

With its powerful and easy-to-understand features PROMODAG Reportsproduces comprehensive reports 
that you can rely on to ensure better security, business continuity, and to improve Exchange organization 
performance. 

PROMODAG Reports is easy to install and configure. Reports use native Exchange server data sources; so 
there is nothing to install on the server. The product collects and stores the necessary data into an Access or 
SQL Server database. You can choose from over 80 ready-made reports and publish them to various 
destinations in different formats. All operations can be easily automated and scheduled so you can set up 
the product and forget about it.  
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Support 

Your support options include the following :  

Self-help resources  
Please browse the following self-help resources before placing a support request, as they may indeed 
contain the solution to your problem and save your time:  

1. This Quick Start Guide: it will give you the basic information needed to install and configure the 
product.  

2. The Online help (http://www.promodag.com/support/OnlineHelp/Repex.htm) will give you a more 
detailed information on PROMODAG Reports , from licensing to troubleshooting.  

3. The Knowledge Base (http://www.promodag.com/Portal/KB/root.aspx): it contains answers to 
common questions.  

How to submit a support request  
If you still have not found an answer to your question, you may submit a request to our Customer Support 
team under the following conditions:  

• You are evaluating the product: Support for PROMODAG Reports is free of charge during the 
45-day trial period. However, you can submit up to 2 tickets via email (or use the Help > Technical 
Support Request option in the product).  

• You are an existing customer and your maintenance plan is currently valid: There is no limit to 
the number of technical support requests you can submit, either  

a. via email: support@promodag.com (or use the Help > Technical Support Request option in 
the product); 

b.  by phone: +33 1 53 27 66 60 or Toll Free (from USA only): 1(888) 696-5404.  

• You are an existing customer and your maintenance plan is no longer valid: You cannot submit 
any technical support request. However, you can subscribe at any time, just request a quotation 
from our sales department with your license number.  

Note: We normally respond within 2 hours, but please allow 24 hours for us to respond to account 
for differences in international time zones. Our office hours are 10:00 to 19:00 GMT+1 (Paris), 
Monday to Friday.  

http://www.promodag.com/downloads/documentation/quickstartV8.pdf
http://www.promodag.com/support/OnlineHelp/Repex.htm
http://www.promodag.com/kb/default.aspx
mailto:support@promodag.com?subject=Your%20Promodag%20Reports%20support%20request
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Reports data sources 

PROMODAG Reports uses different data sources to produce its various reports. 

 

Data source 
name 

Description Configuration 

Messages 
tracking files 

This data source is used to produce various reports on email traffic. 
Microsoft Exchange Server uses message tracking files to record all 
mail activity. Each message received or sent from or to the server 
writes an event in the daily message tracking file. PROMODAG 
Reports reads these files, analyzes their content and stores the result in 
its database.  

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Directory This data source is used to produce reports on directory objects. The 
application must retrieve all recipients from Active Directory in order 
to be able to identify directory objects. For instance, this information 
is used to list and group mailboxes attributes (department, country...). 
Data is stored in the database.  

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Internet 
Information 
Services Files 

This data source is used to produce reports on OWA (Outlook Web 
Access) usage. PROMODAG reports reads the Internet Information 
Services log files, then store the information in its database. This 
feature is not available with Microsoft Exchange version 4.0, 5.x. 

IIS 6.0 

Mailbox and 
public folder 
size import 

This data source is used to produce reports on mailbox and public 
folder size. Information is based on a 'snapshot' taken at the time when 
the import is run. It is dynamically collected through a MAPI 
connection to the Exchange server. Data is stored in the database.  

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Dynamic 
mailbox and 
public folder 
size 

This data source is used to produce reports on mailbox and public 
folder size. Information is based on a 'snapshot' taken at the time when 
the import is run. It is dynamically collected through a MAPI 
connection to the Exchange server. However, data is not stored in the 
database whereas this is the case with the mailbox and public folder 
size import data source. 

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Mailbox and 
Public Folder 
content 

This data source is used to produce reports on mailbox and public 
folder content. Information is based on a 'snapshot' taken at the time 
when the report is run. It is dynamically collected through a MAPI 
connection to the Exchange server. Data is not stored in the database. 

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Information 
Store size  

This data source is used to produce reports on Information Store size. 
Information Store size import is based on a 'snapshot' taken at the time 
when the import is run. It records the size of the EDB and STM files 
found on the Exchange server. Data is stored in the database. 

Exchange 4.0, 
5.x 
Exchange 2000, 
2003 
Exchange 2007 

Internet Mail 
Service archival 

This data source contains all messages that have gone through the 
Internet Mail Connector. The archives give the subject of messages 
received from or sent to the Internet. This feature is only available 
with Microsoft Exchange version 4.0, 5.x. 

 Exchange 4.0, 
5.x only 
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Configuring your environment 

 Setting up your environment 

Supported versions of Microsoft Exchange  

PROMODAG Reports supports all versions of Microsoft Exchange Server (4.0, 5.0, 5.5, 2000, 2003, 
2007). It is possible to use the product with a mix of different Exchange Server versions.  

Note: PROMODAG Reports must be installed on a workstation and not on a Microsoft Exchange 
Server. 

Microsoft Exchange Server requirements 

You do not need to install anything on the Exchange Server, or to modify anything in your Exchange 
organization. The following topics describe in detail the few steps to follow to import data from Exchange 
or Internet Information Services into PROMODAG Reports.  

Configuring Exchange Server 2000, 2003 

Configuring Exchange 2000, 2003 for directory import 

Introduction 

This data source is used to produce reports on directory objects. The application must retrieve all recipients 
from Active Directory in order to be able to identify directory objects. For instance, this information is used 
to list and group mailboxes attributes (department, country...). Data is stored in the database.  

How to configure Exchange 2000, 2003 to import the directory via an LDAP 
connection 

You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the directory via an LDAP connection.   

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange System Manager tool. 

• Start Exchange System Manager. 

• Right-click the Exchange organization name. 

• Choose Delegate control . 
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• Select your NT account and set its role to Exchange View Only Administrator. 

 

 

Message tracking files on Exchange Server 2000, 2003  

Introduction  

This data source is used to produce various reports on email traffic. Microsoft Exchange Server uses 
message tracking files to record all mail activity. Each message received or sent from or to the server writes 
an event in the daily message tracking file. PROMODAG Reports reads these files, analyzes their content 
and stores the result in its database.  
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Message Tracking Files location   

 The default path for the directory where message tracking files are generated on the Exchange 2000, 2003 
server is: 

C:\Program Files\Exchsrvr\<server name>.log. This directory is shared by default and its name is 
<server name>.log. 

By default, PROMODAG Reports tries to read message tracking files through the following UNC: 
'\\<server name>\server_name.log\'  
This default path can be configured in the Message Tracking tab of the Server Properties dialog box of 
PROMODAG Reports. 

Rights and permissions 

The NT account used to start PROMODAG Reports (or the administrative account defined in Server 
Properties, Security tab) must have at least access Read-Only permissions to the message tracking files 
shared folder. 

Note: It is also possible to copy message tracking files on a local or a network share, and import them 
from there. 

Enabling Message tracking 

If message tracking is not enabled at the server level on the Exchange server, PROMODAG Reports will 
not work. A decision should be made on how long these files are to be kept on the server (see also "How 
long should message tracking files be kept ?" on page 11 

 Enabling message tracking in the Microsoft Exchange Server requires a Microsoft Exchange Server 
administrator role and can be setup using Exchange System Manager tool. 

To enable message tracking, right-click the Exchange 200x server and click Properties. You can also 
choose Properties from the Action menu.  

 

On the General tab, check the Enable subject logging and display and Enable message tracking boxes.  
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How long should message tracking files be kept ? 

By default, Microsoft Exchange Server keeps message tracking files for a duration of 7 days. This default 
setting can be changed in the Log file maintenance parameters to accommodate different needs.For 
example, they must be kept 31 days if message tracking files are only imported once a month in 
PROMODAG Reports. 

For more information on how to enable message tracking in Exchange 2000 Server and in Exchange Server 
2003, see the Microsoft Knowledge Base or Microsoft Technet. 

Mailbox and Public Folder content on Exchange 2000, 2003 

Introduction 

This data source is used to produce reports on mailbox and public folder content. Information is based on a 
'snapshot' taken at the time when the report is run. It is dynamically collected through a MAPI connection 
to the Exchange server. Data is not stored in the database. 

Rights and permissions 

You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the content of mailboxes and public folders. 

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange System Manager tool.  

http://support.microsoft.com/kb/246856/en-us
http://www.microsoft.com/technet/prodtechnol/exchange/2000/maintain/15x2kada.mspx
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• Start Exchange System Manager. 

• Right-click the Exchange organization name. 

• Choose Delegate control . 

 

• Select your NT account and set its role to Exchange View Only Administrator. 
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Mailbox and public folder size on Exchange Server 2000, 2003 

Introduction 

Mailbox and public folder size import 
This data source is used to produce reports on mailbox and public folder size. Information is based on a 
'snapshot' taken at the time when the import is run. It is dynamically collected through a MAPI connection 
to the Exchange server. Data is stored in the database.  

Dynamic mailbox and public folder size 
This data source is used to produce reports on mailbox and public folder size. Information is based on a 
'snapshot' taken at the time when the import is run. It is dynamically collected through a MAPI connection 
to the Exchange server. However, data is not stored in the database whereas this is the case with the 
mailbox and public folder size import data source. 

Rights and permissions 

You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the size of mailboxes and public folders. 

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange System Manager tool.  

• Start Exchange System Manager. 

• Right-click the Exchange organization name. 

• Choose Delegate control . 

 

• Select your NT account and set its role to Exchange View Only Administrator. 
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Information Store size on Exchange 2000, 2003 

Introduction 

This data source is used to produce reports on Information Store size. Information Store size import is 
based on a 'snapshot' taken at the time when the import is run. It records the size of the EDB and STM files 
found on the Exchange server. Data is stored in the database. 

 Databases location 

The default paths for the mailboxes and public folders databases directories when you install Exchange 
2000, 2003 are: 

• C:\Program Files\Exchsrvr\mdbdata\priv1.edb  and C:\Program 
Files\Exchsrvr\mdbdata\priv1.stm (mailboxes).  

• C:\Program Files\Exchsrvr\mdbdata\pub1.edb and C:\Program 
Files\Exchsrvr\mdbdata\pub1.stm (public folders). 

These default paths can be configured in the Storage Size tab of the Server Properties dialog box of 
PROMODAG Reports. 

Rights and permissions 

The NT account used to start PROMODAG Reports (or the administrative account defined in Server 
Properties, Security tab) must have at least access Read-Only permissions to the Exchange Information 
Stores (EDB and STM files). 
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Configuring Exchange Server 2007 

Configuring Exchange 2007 for directory import 

Introduction 

This data source is used to produce reports on directory objects. The application must retrieve all recipients 
from Active Directory in order to be able to identify directory objects. For instance, this information is used 
to list and group mailboxes attributes (department, country...). Data is stored in the database.  

How to configure Exchange 2007 to import the directory via an LDAP connection 

 You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the directory via an LDAP connection.   

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange Management Console tool. 

• Start the Exchange Management Console tool. 

• Right-click Organization Configuration and select the Add Exchange Administrator option. 

 

• Select the relevant NT account and set its role to Exchange View Only Administrator. 
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Message tracking files on Exchange Server 2007 

Introduction 

This data source is used to produce various reports on email traffic. Microsoft Exchange Server uses 
message tracking files to record all mail activity. Each message received or sent from or to the server writes 
an event in the daily message tracking file. PROMODAG Reports reads these files, analyzes their content 
and stores the result in its database.  

Message tracking files and Exchange 2007 server roles 

Hub Transport server and Edge Transport server roles perform message transport functionality. Only those 
servers generate message tracking files that may be imported in PROMODAG Reports , in opposition to 
Mailbox servers, of which message tracking files are not imported.  

The name format for message tracking file generated by those server role are: 

• MSGTRKyyyymmdd-1.LOG for Hub Transport or Edge Transport servers .  

• MSGTRKMyyyymmdd-1.LOG (NB: the name contains an additional M) for Mailbox servers. 

A server where both Hub/Edge Transport and Mailbox roles are installed will generate both types of files. 
However, PROMODAG Reports will only import message tracking files generated by the Hub or Edge 
role.  

Message Tracking Files location  

The default path for the directory where message tracking files are generated on the Exchange 2007 server 
is: 

C:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\MessageTracking. This folder is 
not shared by default. 

PROMODAG Reports tries to read message tracking files through the following UNC, which requires 
administrative privileges: 
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'C$\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\MessageTracking'. Therefore, 
two solutions are possible: 

• use an administrative account to run PROMODAG Reports; 

• share the MessageTracking folder, and grant Read-Only permissions to the account used to run 
PROMODAG Reports. 

This default path can be configured in the Message Tracking tab of the Server Properties dialog box of 
PROMODAG Reports. 

Rights and permissions 

The NT account used to start PROMODAG Reports (or the administrative account defined in Server 
Properties, Security tab) must have at least access Read-Only permissions to the message tracking files 
shared folder. This folder is not shared by default. 

Note: It is also possible to copy message tracking files on a local or a network share, and import them 
from there. 

Enabling message tracking 

By default, message tracking is enabled on all Exchange 2007 computers that have the Hub Transport, 
Mailbox, or Edge Transport server roles installed.  

Note: You can enable or disable message tracking by using the Exchange Management Console in 
Exchange 2007 SP1 only.  

To use the Exchange Management Console to enable or disable message tracking on 
a Hub Transport server or Edge Transport server in Exchange 2007 SP1:  

1. Open the Exchange Management Console. Perform one of the following steps:  
 
- On a computer that has the Edge Transport server role installed, select Edge Transport, and then in 
the action pane, click the Properties link that is directly under the server name.  
- On a computer that has the Hub Transport server role installed, in the console tree, expand Server 
Configuration, and select Hub Transport. In the action pane, click the Properties link that is directly 
under the server name.  

2. In the Properties page, click the Log Settings tab.  

3. In the Message tracking files section, perform one of the following steps:  
 
- Select Enable message tracking log to enable message tracking.  
- Clear Enable message tracking log to disable message tracking.  

4. Click Apply to save changes and remain in the Properties page, or click OK to save changes and 
exit the Properties page.  

For more information on how to configure message tracking in Exchange 2007, see Microsoft Technet. 

http://technet.microsoft.com/en-us/library/aa997984.aspx
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Mailbox and Public Folder content on Exchange 2007 

Introduction 

This data source is used to produce reports on mailbox and public folder content. Information is based on a 
'snapshot' taken at the time when the report is run. It is dynamically collected through a MAPI connection 
to the Exchange server. Data is not stored in the database. 

Rights and permissions 

You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the content of mailboxes and public folders. 

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange Management Console tool. 

• Start the Exchange Management Console tool. 

• Right-click Organization Configuration and select the Add Exchange Administrator option. 

 

• Select the relevant NT account and set its role to Exchange View Only Administrator. 
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Mailbox and public folder size on Exchange 2007 

Introduction 

Mailbox and public folder size import 
This data source is used to produce reports on mailbox and public folder size. Information is based on a 
'snapshot' taken at the time when the import is run. It is dynamically collected through a MAPI connection 
to the Exchange server. Data is stored in the database.  

Dynamic mailbox and public folder size 
This data source is used to produce reports on mailbox and public folder size. Information is based on a 
'snapshot' taken at the time when the import is run. It is dynamically collected through a MAPI connection 
to the Exchange server. However, data is not stored in the database whereas this is the case with the 
mailbox and public folder size import data source. 

Rights and permissions 

You must be logged in with an account that has at least the Exchange View Only Administrator role on the 
Exchange organization in order to be able to import the size of mailboxes and public folders. 

Enabling such permission requires a Microsoft Exchange Server administrator role and can be setup with 
the Exchange Management Console tool. 

• Start the Exchange Management Console tool. 

• Right-click Organization Configuration and select the Add Exchange Administrator option. 
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• Select the relevant NT account and set its role to Exchange View Only Administrator. 
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Information Store size on Exchange 2007 

Introduction 

This data source is used to produce reports on Information Store size. Information Store size import is 
based on a 'snapshot' taken at the time when the import is run. It records the size of the EDB and STM files 
found on the Exchange server. Data is stored in the database. 

Databases location 

The default paths for the mailboxes and public folders databases directories when you install Exchange 
2007 are: 

• C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox 
database.edb (mailboxes) 

• C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Public Folder 
database.ebd (public folders). 

These default paths can be configured in the Storage Size tab of the Server Properties dialog box of 
PROMODAG Reports. 

Rights and permissions 

The NT account used to start PROMODAG Reports (or the administrative account defined in Server 
Properties, Security tab) must have at least access Read-Only permissions to the Exchange Information 
Stores (EDB and STM files). 

  

Configuring Internet Information Services 

Internet Information Services (IIS version 6.0) logs 

Introduction 

This data source is used to produce reports on OWA (Outlook Web Access) usage. PROMODAG reports 
reads the Internet Information Services log files, then store the information in its database. This feature is 
not available with Microsoft Exchange version 4.0, 5.x. 

Enabling logging in IIS 6.0 

Expand the server name, right-click Default Web Site for each OWA site, and select Properties. 

 

Under the Web Site tab, verify that theEnable logging checkbox is ticked, then click the Properties button 
to access the Extended Logging Properties dialog box. 
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Under the General Properties tab, verify that the New Log Time Period schedule is set to Daily and click 
the Advanced tab. 
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On the Advanced tab, confirm that at least the following logging options are selected: 

• Date (date) 

• Time (time) 

• Client IP address (c-ip) 

• User Name (cs-username) 

• Method (cs-method) 

• URI Stem (cs-uri-stem) 

• URI Query (cs-uri-query). 
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Rights and permissions 

The NT account used to start PROMODAG Reports (or the administrative account defined in Server 
Properties, Security tab) must have at least access Read-Only permissions to the Internet Information 
Services files shared folder. 

Note: It is also possible to copy message tracking files on a local or a network share, and import them 
from there. 
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Installation 

System requirements 

Note: PROMODAG Reports must be installed on a workstation and not on a Microsoft Exchange Server. 

Workstation hardware requirements  
• A 2 GHz Intel Pentium processor.  

• 512 MB of system memory. 

• Enough disk space to store the database.  

 Workstation software requirements 
• Windows 2000 SP4, XP SP2, 2003 SP2, Vista SP1, 2008. 

• Microsoft Outlook 2000, XP SP1, 2003, 2007 in order to install MAPI. 

• Microsoft .NET Framework 2.0 SP1. 

• MDAC 2.8 (Microsoft Data Access Components). 

Note: Outlook 2007: Make sure that you select a custom installation in order to install the Outlook MAPI Service 
Providers components (please see "Installing MAPI with Outlook 2007" on page 26 for additional information). 
Outlook XP SP1 is required due to a bug in the initial release that prevented some reports from working. 

Optional requirements  

For the Enterprise Edition you need Microsoft SQL Server 2000 (SP3 or SP4), 2005 or 2008. 
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Installing MAPI with Outlook 2007 
The MAPI component is not installed by default with Microsoft Outlook 2007.  

Choose a custom installation of Outlook or Office in order to install it, and then choose to install Outlook Messaging 
Components. 

 

Upgrading from a previous version 

Installing the new version  

If a previous version of PROMODAG Reports is already installed on your system, install Version 8 into a different 
directory. You will be able to use both versions, but with different databases. 

Upgrading the database  

Your existing database needs to be converted to be functional with PROMODAG Reports version 8. The database 
conversion process is included in version 8 and should be carried out automatically; however, it can take some time 
according to your database size. 

Note: Please make sure you backup your database before upgrading.  
A version 8 database cannot work with previous versions of PROMODAG Reports. 

Upgrading Favorites, report option files and batch files 

If report option files (extension PRO) and Favorites were created in a previous version, you can convert them with 
the Tools > Report Option File migration option. The report option files you created in version 7 should be located 
in the C:\Documents and Settings\All Users\Application Data\Promodag\Reports\7\Batches folder.  

This option also converts batch files (extension PRB). 

Note: Since some options may have changed, verify that you obtain the expected report with the converted files. 

What cannot be upgraded 

Scheduled tasks are not upgraded. You will have to delete your existing tasks, and create new ones. Report option 
files and batch files created with a version prior to PROMODAG Reports version 7 are not upgraded. 
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Quick Tour 

Starting PROMODAG Reports 
From the Start Menu, choose Programs > Promodag > PROMODAG Reports 8.  
The following window appears when the application is started for the first time:   

 

  

The wizard provides you with instructions for: 

1. Creating a new PROMODAG Reports database, 

2. Connecting to the directory, 

3. Connecting to your Exchange server(s), 

4. Choosing the type of data you want to import:  

a. Message tracking files,  

b. Storage size: 

• Mailbox size,  

• Information Store size,  

• Mailbox count per Information Store,  

• Public folder size, 

c. Internet Information Services log files, 

5. Selecting presentation options, 

6. Selecting reports to run at the end of the wizard (optional), 

7. Scheduling and automatic import task (optional), 

8. Starting the data collection process. 
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Choosing a database format 

Database purpose 

 PROMODAG Reports creates a Microsoft Access or SQL Server relational database using Microsoft Exchange 
Server data sources (Exchange directory, message tracking files and Internet Mail Connector archives. The 
application stores in this database the information it needs to build reports. There is no limitation to the number of 
databases that can be created.  

• To create a new database, choose File > New Database or click the  button. 

• To open an existing database File > Open Database or click the  button. 

• The last 10 opened databases are listed in the File menu. 

Available database formats 

The PROMODAG Reports database has a specific structure and supports two different formats. 

Microsoft Access databases 
• Database has a size limit of 2 GB 

• Database file must be located on same machine as PROMODAG Reports 

• No multi-user access 

• No additional cost  

• Best suited for small Exchange organization 

Microsoft SQL Server databases 
• Database size limited by disk space on the SQL Server  

• Multi-user Access 

• Performance is determined by the power of the server. 

• Better scaling 

• Needs for an additional SQL server license 

• Requires the Enterprise edition of PROMODAG Reports 

• Best suited for medium or large Exchange organization 

Note: Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) or SQL Server 2005/2008 Express can be used 
with PROMODAG Reports Enterprise edition; however, database size is limited to 2GB or 4 GB depending on the 
version. Performance will also be inferior to SQL Server. 
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Creating a new PROMODAG Reports database  

Database type selection  

Choose the type of database you wish to use. For more information about available formats, see "Choosing a 
database format" on page 28"Choosing a database format" on page 28"Choosing a database format" on page 28.  

Creating an Access database 

Specify a name for the new Access database (MDB file) as well as a description (optional). 

 

Creating a SQL Server database 

Enter the name of SQL server and specify the name of the new SQL database. You must provide a login name and a 
password to use SQL Server authentication. 

You can use the Advanced button to enter a specific file location for the database. 
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Creating a database based on the current one 

You may either start with a new empty database, or collect some information from your current one. In this case, 
directory and configuration information remain unchanged provided the current database is already open. 

• Select the Directory check box to copy Exchange recipients from your existing database to the new one. 

• Select the Recipient additional attributes check box to copy existing directory attributes to the new database.  

• Select the External recipients check box to copy external addresses from the existing database directory 
(SMTP, MS-Mail...) 

• Select the Connectors check box to copy connectors from your existing database. 

Time Zone selection 

Date and time are expressed in GMT (UTC) in Exchange message tracking files. PROMODAG Reports is able to 
recognize your time zone; so you can either generate reports using GMT, or local time. Time zones with daylight 
saving times can be handled as well. Local time is configured at the database level. The original date and time are 
still recorded in the database so it is always possible to modify the time zone. 

• Select your time zone in the drop-down list. 

• Select the Automatically adjust for daylight saving changes check box to adjust automatically to daylight 
saving change. 

For more information on local time handling, see Local time handling in the embedded Help file. 
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.  
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Configuration Wizard: configuring connections  

Description  

The Configuration Wizard provides an user-friendly interface to start with PROMODAG Reports. It automatically 
appears when the database is empty. The wizard screens enable the user to perform different operations for 
configuring the Exchange Directory and importing message tracking files.  

Connecting to the directory via LDAP 

When you create an empty database, the first step of the Wizard is attempt to retrieve LDAP connection 
information.PROMODAG Reports connects to the Exchange directory via LDAP. To accept the default LDAP 
settings, click the Next button. 

 

  

 
Option Description 

 
Click this button to retrieve automatically the name of a Global Catalog server. 

Global Catalog server Enter the name of the Global Catalog server. It will be used to import the directory. 

 
Click this button to test the LDAP connection with the Global Catalog server. 
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Option Description 

 
This green icon appears if the LDAP connection was successfully established during 
the test. 

Current account Check this radio button if the account you used to log in has sufficient permissions to 
access the directory. 

Specific account Check this radio button to specify an administrative account with necessary 
permissions to access the directory. 

Setting up a valid connection to the Exchange system 

PROMODAG Reports needs to establish a connection with the Exchange system to produce reports on mailbox or 
public folder content. You must at least fill the Mailbox and Exchange Server fields. To accept settings, click the 
Next button. 

 

 
Option Description 

Current account and Specific 
account 

Check the Current account radio button if the account you used to login has 
sufficient permissions for Exchange Server access. Check the Specific account radio 
button to specify an account with necessary permissions for Exchange Server 
access.  

 
Click this button to verify that the account you used to login has sufficient 

permissions for Exchange Server access. The green icon  appears if the account 
you used to login has sufficient permissions for Exchange Server access. 

Click this button to automatically retrieve a mailbox linked to the current/specific 
account. 
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Option Description 

Mailbox Enter the name of the mailbox that will be used to establish a MAPI connection 
with your Exchange server(s). See below resolve the Mailbox Legacy Exchange 
Distinguished Name of the mailbox . Note: it is strongly recommended to create a 
specific mailbox dedicated to this purpose. 

Exchange Server  Enter the name of the Exchange Server where the mailbox is located. 

 
Click this button to test the MAPI connection with the Exchange server. This 
verification will also resolve the Mailbox Legacy Exchange Distinguished Name of 
the mailbox (e.g. 
/o=OrganizationName/ou=AdministrativeGroupName/cn=ContainerName/cn=Mail

boxAlias). The green icon  appears if the MAPI connection was successfully 
established during the test. 

  

Product registration  

The next step allows you either to enter your license information, or to evaluate PROMODAG Reports. 

Enter the license information received from PROMODAG, and make sure that the edition selected and the 
organization name are correct.  

Note: To use PROMODAG Reports in evaluation mode, click Evaluate.  

 

Configuration Wizard: from data collection to reporting 

Choosing data types to be collected   

Select the type of data to import into the database according to the type of reports you wish to run afterwards. 
Additional information will be requested in the following steps according to choices made here. 

Note: These import options can be modified later. For instance, you may decide not to import data related to 
connectors flow to keep your database small. 
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Data sources for traffic reports 

 
Option Description 

User traffic Select this check box to be able to generate reports on mailbox traffic. This is the most 
common source of report. 

Replication traffic Select this check box to be able to generate reports on directory and public folders 
replication traffic. 

Connector flow Select this check box to be able to generate reports on connector flow. Note: Reports 
on connector flow are not available in the Standard edition.  

Non Delivery Reports 
(Exchange 200x only) 

Select this check box to be able to generate reports on NDR.  

Intelligent Message Filter 
(IMF) (Exchange 2003 only) 

Select this check box to be able to generate reports on IMF.  

  

Data sources for storage size reports 

Select these check boxes to choose the type of storage size to be imported: 
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Option Description 

Public folder size Import the size and number of items contained on public folders located on the 
selected servers. 

Mailbox size Import the size and number of items contained in mailboxes located on the selected 
servers. 

Mailbox count per 
Information Store 

Import the number of mailboxes located on the selected servers through an LDAP 
connection to the directory. 

Information store size Import the size of the EDB or STM files contained in information stores located on 
the selected servers. 

Data sources for OWA and ActiveSync reports 

 
Option Description 

Internet Information 
Services files 

Select this check box to be able to generate reports on Outlook Web Access and 
ActiveSync.  

Configure data source for traffic reports   

Highlight the server name to specify from which server(s) data must be imported, and click the  button to 
move it to the right pane (you can also double-click the server name). Message tracking files will then be imported 
from all servers listed in the Selected server(s) pane. 

Select mailbox servers (Exchange 4.0, 5.x or Exchange 2000, 2003) or Hub and Edge servers (Exchange 2007) to 
generate reports on traffic. This selection can be modified later.  

Specify the period you wish to import: 

• From: Date of the first message tracking file to import. 

• To: Date of the last message tracking file to import. The most recent date available is yesterday. 

The location of message tracking files is tested on each selected server when you click the Next button. If a location 
is not valid, a message box appears to allow you to indicate the right location. 
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Configure data source for storage size reports 

Select Exchange servers that will be analyzed to generate storage size reports. 

When you click the Next button, the location of information stores is tested on each selected server. If a location is 
not valid, a message box appears to allow you to indicate the right location. 
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Configure data source for OWA and ActiveSync reports 

Select Exchange servers that will be analyzed to generate OWA and ActiveSync reports.  Click the Next button. 

 

General report options 

Select the following options from the drop-down lists: 

• the default language for your reports (choices available are: English, French, German, Spanish, Italian, 
Portuguese, Dutch) 

• the server name prefix in reports according to Exchange organization layouts (Active Directory site, 
routing group or administrative group). 

Click the Next button. 
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Choosing reports to run at the end of the wizard 

Use this dialog box to select the reports you would like to run automatically once the import process is completed. If 
this is the first time you use the product, you will get a list of predefined reports that are delivered with the product. 
Click the Next button. 

 

 Processing imports. 

At this point, PROMODAG Reports has enough information to start the import process.  

Note: Import options may be saved in a batch file, so that the import process can be automated and scheduled at 
your convenience. See "Automating and scheduling data collection and other actions " on page 47. 
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When clicking on the Finish button, the import process begins. It includes all previously configured steps. 

 PROMODAG Reports  

1. Imports the directory,  

2. Imports message tracking files, 

3. Imports storage size, 

4. Imports IIS files, 

5. Runs selected reports. 
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Running a report: Mailbox by Traffic Level 
Activity level of a group of mailboxes can be analyzed with to the Mailbox by Traffic Level report.  

The report options dialog box can be reached  

• From the Reports menu, 

• From the reports tree, in the left pane of the PROMODAG Reports main window, 

• Or from the Favorites menu if you already saved a report options file (see below, "Generating the report:" on 
page 45). 

In the following example, we are going to address this question: Who sent the most messages outside of the 
organization during a given reporting period ? 

Choose  Reports > Mailbox Traffic > Mailbox by Traffic Level to open the report dialog box. This dialog box 
includes a variety of tabs. Many of them are common to all reports.  

Setting up the report: 

Period tab: 

The purpose of the Period tab is to select a specific reporting period. It is possible to select an absolute or relative 
date range as well as particular days. You can even focus on business hours. 

Activate the Absolute radio button and select the reporting period of your choice in the From andTo fields.  

Note: Make sure that message tracking files covering this date range have been imported.  
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Selection tab: 

The purpose of the Selection tab is to select the group of directory objects (mailboxes, servers...) on which 
PROMODAG Reports is going to report. For example, mailbox type objects can be selected according to various 
Active Directory attributes such as Company, Department or Active Directory Container. 

On the Selection tab, select All organization mailboxes or Mailbox by, then select a particular value from the drop-
down list to limit the number of objects included in the report.  

 

Group tab: 

The purpose of the Group tab is to group the report results at one or more levels of your choice. For instance, you 
may want to group the results of your report by Company at level 1, and by Department at level 2. 

On the Group tab, select the grouping criteria of your choice from the Group by drop-down list.  

 

Partners tab: 

The purpose of the Partners tab is to filter the analyzed traffic by  partner types, such as Exchange, Internet or Fax. 

On the Partners tab, activate the Some partners radio button, then limit the partner types to Internet messages only 
by selecting Internet like * in the partners selection grid.  
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Options tab: 

The purpose of the Options tab is to select various sorting options of the report results. 

 Tabular data settings section: 

If the Show only box is checked,enter the number of mailboxes to be displayed in the field located below. To change 
this number, type over it. 

• You can sort by volume of messages received/sent by clicking on Show only, Biggest/Smallest, Size, 
Received/Sent. 

• You can sort by number of messages received/sent by clicking on Show only, Biggest/Smallest, Number, 
Received/Sent. The display order selected in the example below is:  Number, Received. 

 Sort by option: 

• You can select only one of two options. The list can be sorted in ascending or descending order. The sorting 
order selected in the example below is: Number, Descending. 

Count a multiple sending as section : 

Determine whether a message sent to n recipients is counted as 1 sent message or n sent messages. You can select 
only one of two options. 
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Content tab: 

The purpose of the Content tab is to select the detail level of the final report, and the direction of the traffic (Sent, 
Received). 

 
Option Description 

Partner type Check this box to display the partner type in the report. 

Optional mailbox 
attribute 

Select one directory attribute related to mailboxes, such as their email addresses, to display in 
the report. 

Messages Choose the direction of traffic to display in the report: sent messages, received messages, 
and/or total. 

Mailboxes with no 
traffic 

Check this box to display those of the selected mailboxes for which no traffic can be reported 
during the chosen period. 

Anonymous report You may select this option for confidentiality reasons. Check this box to obtain a report 
without showing mailbox names. The names will be replaced with a standard label and a 
counter. 
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Output tab: 

The purpose of the Output tab is to choose the output destination of the final report. 

Specify the output format. Reports can be output to screen or exported in different formats to the location of your 
choice. In the example below, the report will be displayed on screen. 

 

Generating the report: 

Once all report options have been set, click the OK button to generate the report. PROMODAG Reports retrieves the 
information it needs in the database and queries it to produce the requested report. The report appears in a preview 
window.  
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This previewed report can be: 

• Printed: click the     button or go to File > Print Report. 

• Exported: click the   button or go to File >Export Report. 

• Reloaded: click the  button or go to File > Reload Report.  

• Saved: click the  button or go to File > Save Report. 

Saving the report: 

You can either save the report itself as a snapshot, or a report option file that you will be able to use later on in a 
batch file (see"Batch files and report options files" on page 47), or decide to save it as a Favorite, that is a customized 
report options file directly available from the Favorites menu. It is recommended that you give it a meaningful title, 
such as Top Internet senders. This title will make it easier for you to locate your report option files in the Favorites 
menu, or in the left pane of the Task Automation menu (Actions and Reports list), see "Automating and scheduling 
reports generation" on page 52. 
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Advanced Features 

Batch files and report options files 

What is a batch file ? 

A batch file is a text file containing one or more commands: report generation, data import or other action. Batch 
files are useful if you need to import data out of business hours, or to generate and publish pre-defined reports 
automatically . By default, batch files are saved under the %ALLUSERSPROFILE%\Application 
Data\Promodag\Reports\8\Batches folder with a PRB extension. 

What is a report options file ? 

A PROMODAG Report Options file is a text file describing options for a report. Report options files contain a 
whole set of options for a given report (date, server, sort,...). By default, report option files are saved under the 
%ALLUSERSPROFILE%\Application Data\Promodag\Reports\8\Batches folder with a PRO extension. 

Automating and scheduling data collection and other actions   
PROMODAG Reports can be configured to import message tracking files and, for instance, delete obsolete data by 
following these steps: 

1.  Create a batch file and choose what should be imported.  

2.  Schedule the batch file using Windows standard scheduler.  

 In the following example, we are going to create and schedule a batch file to automate 

• message tracking files import 

•  imported data deletion if older than 90 days. 

Step 1: Creating a batch file  

Use the Tools > Task Automation menu to access the automation screen. Click the New batch button, enter a file 
name and a description.  

 

Exploring available actions  

Click and expand available actions in the Actions section of the Actions and Reports tree: 
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Action Description 

Database 
Specification 

Select a specific database to be used when the 
batch job runs.  

Batch Trace File 
Location 

Select a location where trace files will be 
generated. 

Create HTML TOC Create an HTML file including a TOC (Table 
of Content) with links to exported reports 
included in the batch. 

Directory Connection Choose a specific directory connection to be 
used when the batch job runs. 

Exchange Connection Choose a specific Exchange connection to be 
used when the batch job runs. 

Clear Imports Delete old messages from the database. 

 Import Directory Import or update the Exchange directory. 

 Import Message 
Tracking Files  

Import message tracking files. 

 Import Internet 
Information Services 

Import Internet Information Services log files. 

 Import Storage 
Size 

Import information store size. 

Import IMC Archives Import Internet mail connector archives (when 
applicable). 

Compact database Compact or shrink the database to reclaim 
unused disk space. 

Adding the Import Message Tracking Files action   

Select Import Message Tracking Files in the Actions tree, then click the  button. The default settings will 
import messages tracking files for the selected servers from the last import date up to yesterday. Click  OK to save.  
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Adding the Clear Imports action   

You may decide that you only need three months of message tracking files in your database. PROMODAG Reports 
is able to clear automatically obsolete data.  

In the Actions tree, select Clear Imports, then click the  button.  

Highlight the server name to specify from which server(s) data must be cleared, and click the  button to move 
it to the right pane (you can also double-click the server name). Data will then be deleted from all servers listed in the 
Selected server(s) pane. 

Select the period to clear, and the type of data to remove. In this example, we chose to delete message tracking files 
and Internet Information Services files imported before the last 90 days. Click OK to save. 
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Step 2: Scheduling the batch file  

Use the Tools > Task Automation menu to access the automation screen. In the Batch file name drop-down list, select 
the batch file to schedule. In this example, we want to schedule PeriodicImport.prb. 

 

Note: By default, actions will be carried out on the last database opened, unless you specify which database must be 
used (action: Database specification).  

 Click the Schedule button. 
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Check that the account in the Run as box is the same as the one you use for PROMODAG Reports in interactive 
mode. Use the Set password button. Select the Schedule tab and create a new scheduler.  

 

Note: For more details on this dialog box, see the Microsoft Windows Help system. 

Step 3: Running the batch file 

 The Windows Task Scheduler starts PROMODAG Reports at the scheduled time. It processes actions included in 
the batch file. 



 52 Getting started with PROMODAG Reports   

PROMODAG Reports generates a trace file that contains information on what happened while the batch was 
running. Trace files can be automatically emailed.  

Automating and scheduling reports generation 
 In the following example, we are going to create and schedule a batch file to automate the Mailbox by Traffic 
Level report we have learned to set up earlier (see "Running a report: Mailbox by Traffic Level" on page 41). 

PROMODAG Reports can be configured to generate reports automatically by following these steps: 

1. Create one or more report options file(s). 

2. Create a batch file and choose what report(s) should be generated. 

3. Schedule the batch file using the Windows standard Scheduler. 

Step 1: Creating a reports option file  

See "Running a report: Mailbox by Traffic Level" on page 41 to check how to create a report options file. 

Note: Screen is not a valid output destination if you run the report in batch mode. 

Step 2: Creating a batch file  

Use the Tools > Task Automation menu to access the Task Automation screen. Click the New batch button, enter a 
file name and a description. 

 

Exploring available reports 

The left pane of theTask Automation window lists all actions and reports that can be automated.  

Locate the Mailbox by Traffic Level report in the  Actions and Reports list.  

Reports are classified in the same order as in the Reports menu. Therefore, you will find Mailbox by Traffic Level 
in the Mailbox Traffic folder. 
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Adding the Mailbox by Traffic Level report 

Select the report options file entitled Top Internet senders and click the  button to insert it into the right pane 
(Batch file content). 

 

Step 3: Scheduling the batch file 

Use the Tools > Task Automation menu to access the automation screen. In the Batch file name list box, select the 
batch file to schedule. In this example, we want to schedule DailyReports.prb.  
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Click the Schedule button. 

 

Check that the account in the Run as box is the same as the one you use for PROMODAG Reports in interactive 
mode. Use the Set password functionality. Select the Schedule tab and create a new scheduled task.  
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Note: For more details on this dialog box, see the Microsoft Windows Help system. 

 Step 4: Running the batch file 

 PROMODAG Reports executes and processes the commands included in the batch file at the scheduled time. 

PROMODAG Reports generates a trace file that contains information on what happened while the batch was 
running. Trace files can be automatically emailed.  
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